Każdy z nas ma swoje ulubione dodatki do przeglądarki Mozilla Firefox, które ułatwiają i umilają codzienne korzystanie z Internetu. Część z was patrzy pewnie z niepokojem na kolejne aktualizacje Firefoksa mając na względzie obawę, że ulubiony dodatek przestanie być kompatybilny z najnowszą wersją programu.

Dzieje się tak zazwyczaj gdy autor dodatku nie zareaguje szybko na wydanie nowszej wersji przeglądarki i nie zmieni w kodzie dodatku informacji o kompatybilności z nową wersją. Choć wówczas Firefox informuje nas, że dodatek nie jest kompatybilny z tą wersją, to jednak w większości przypadków okazuje się, że dodatek poprawnie współpracuję z nową wersją przeglądarki, a Firefox jakby na wyrost informuje nas o niekompatybilności.

Możemy jednak odpowiednio skonfigurować przeglądarkę, tak by wymusić uruchomienie niekompatybilnych dodatków. Cały czas musimy jednak zachować ostrożność, gdyż może się okazać, że któryś z dodatków rzeczywiście niepoprawnie współpracuje z najnowszą wersją i powoduje różnorakie błędy w działaniu programu.

Jak wymusić uruchamianie niekompatybilnych dodatków?

1. W pasku adresu wpisujemy about:config i naciskamy przycisk enter.

2. Firefox wyświetli ostrzeżenie. Przechodzimy dalej klikając na przycisk Zachowam ostrożność, obiecuję!

3. Klikamy prawym przyciskiem myszy gdzieś na wyświetlonej liście i z menu wybieramy kolejno Dodaj ustawienie typu, a następnie wartość logiczna (Boolean).

4. W wyświetlonym oknie wprowadzamy nazwę extensions.checkCompatibility i zatwierdzamy klawiszem OK.

5. W kolejnym oknie ustawiamy wartość logiczną na false.

6. Teraz wystarczy już tylko zrestartować Firefoksa. Po ponownym uruchomieniu program automatycznie włączy wszystkie niekompatybilne dodatki.


3 komentarze to “Firefox: wymuszamy uruchamianie niekompatybilnych dodatkow”

  1. zxc napisał(a):

    dupa nie działa

  2. REne napisał(a):

    Nie działa.

  3. mojomr napisał(a):

    Działa, działa. Wystarczy dodać nową wartość logiczną i wpisać odpowiednią frazę (jak wyżej) dodając NUMER WERSJI PRZEGLĄDARKI (np. 16.0)

Skomentuj